参考

0000935: gmime last version not supported - DBMail Bug Tracker

依存

(必ず必要なもの)

・SQLサーバ。MySQL(※), PostgreSQL, SQLite のいずれか。
・SMTP MTA。Postfix, Exim, Qmail, Sendmail 等。
・Glibライブラリ2.8.0以降
・Gmimeライブラリ2.1.19以降

(あれば良いもの)

・Sieve mail sorting language を使うなら、libSieveライブラリ。
・LDAPユーザ認証を行うなら、OpenLDAP。


※MySQLの例:mysql, mysql-server, mysql-devel をインストール。

インストール

yumでインストール

# yum -y install dbmail
# yum -y install dbmail-mysql

ソースからインストール

# yum -y install gcc
# yum -y install glib glib2 glibc
# yum -y install glib2-devel
<del># yum -y install gmime
# yum -y install gmime-devel</del>
# yum -y install gmime20 gmime-devel (たぶん不要)
# yum -y install autoconf automake libtool
# yum -y install zlib-devel
# yum -y install libgpg-error-devel
# yum -y install mhash mhash-devel
# yum -y install libevent-devel
# yum -y install openssl-devel
# yum -y install flex
# yum -y install mysql-devel
# yum -y install libgcj-devel
# yum -y install libstdc++-devel
# yum -y install gcc-c++
# yum -y install perl-CPAN
# yum -y install perl-CORBA-IOP-IOR
# yum -y python-devel
# cd
# wget http://ftp.acc.umu.se/pub/GNOME/sources/gmime/2.6/gmime-2.6.10.tar.xz
# tar Jxvf gmime-2.6.10.tar.xz
# cd gmime-2.6.10
# ./configure
# make
# make install
# wget http://www.tildeslash.com/libzdb/dist/libzdb-2.10.5.tar.gz
# tar xzvf libzdb-2.10.5.tar.gz
# cd libzdb-2.10.5
# ./configure
# make
# make install
# wget http://jaist.dl.sourceforge.net/project/omniorb/omniORB/omniORB-4.1.6/omniORB-4.1.6.tar.bz2
# tar xvf omniORB-4.1.6.tar.bz2
# cd omniORB-4.1.6
# ./configure
# make
# make install
# perl -MCPAN -e shell
cpan> install CORBA::ORBit
# wget http://download.oracle.com/otn/berkeley-db/db-5.3.21.tar.gz (認証が必要)
# tar xzvf db-5.3.21.tar.gz
# cd db-5.3.21
# cd build_unix
# ../dist/configure
# make
# make install
# wget http://jaist.dl.sourceforge.net/project/zource/zdb/v1.0/zdb-1.0.tar.gz
# tar xzvf zdb-1.0.tar.gz
# cd zdb-1.0
# ./configure
# cd
# wget --content-disposition http://dbmail.org/mantis/file_download.php?file_id=532\&type=bug
# wget http://www.dbmail.org/download/3.0/dbmail-3.0.2.tar.gz
# tar xzvf dbmail-3.0.2.tar.gz
# cd dbmail-3.0.2
# patch < ../dbmail-3.0.0_rc3-gmime26.patch 
# autoreconf
# sed -i -e "s/gmime-2.4/gmime-2.5/" -e "s/2.4.6/2.5.3/" acinclude.m4 (必要なら現行の gmime のバージョンに書き換える)
# sed -i -e "s/2.68/2.63/" aclocal.m4 (必要なら現行の autoconf のバージョンに書き換える)
# autoreconf -i (上記コマンドを実行したなら)
# ./configure PKG_CONFIG_PATH=/usr/local/lib/pkgconfig

バージョン確認

# rpm -q dbmail
# rpm -q dbmail-mysql

dbmail-lmtpd準備

24番ポート開放

system-config-securitylevel-tui

自動起動

chkconfig --level 35 dbmail-lmtpd on